企业管理及信息化解决方案;--因为专注,所以专业!
客服热线:028-86272612
成都蓝源 -> > Ext资讯 -> 详细内容
Ext JS 3升级到Ext JS 4
时间: 2012-05-02    来源:

Ext JS 4 是有史以来改动为全方面的一个版本。有彻底重写的诸如DataCharting包,还有做了大手术的TreeGrid这样的组件。Ext JS4在功能性和灵活性上将富客户端开发提升了一个档次。

一方面,为框架增加更多的功能,另一方面,Ext JS 4把所有的API都重新过了一遍,保证所有代码的一致性。为了达到这个目标,很遗憾,Ext JS4不能完全的向后兼容Ext JS 3。但是,我们肯定很明确的指导,需要为大家提供一个平滑升级到Ext JS 4的方案。

我们很高兴的向大家介绍我们推出的用于将现有的Ext JS 3应用升级到Ext JS 4的工具,希望能把系统升级的代价小化。下面是一些由Ext JS 3升级到Ext JS 4的升级包:

· Ext JS 3 Compatibility LayerExt JS3 兼容层

· Ext JS 3 to 4 Migration Guide (Ext JS 3 to 4 升级指南)

· Ext JS Migration Demo App (Ext JS 升级示例应用)

· Ext JS Migration Screencasts (Ext JS 升级截屏视频)

Download the Ext JS 3 to 4 Migration Pack (Updated October 20, 2011)

Ext JS 3 Compatibility Layer

一组代码文件,将这组文件放到Ext JS4下面,能让已有的Ext JS 3的代码在4下面正常执行。这一补丁文件提供给大家,不是让大家只满足于将已有的系统运行起来,这只是一个临时的对策,您就有更宽裕的时间来逐步的将应用完整的迁移到Ext 4之上,你们就把这个文件看成是一个临时的止痛剂吧。

Ext JS 3 to 4 Migration Guide

这个指南只是从一个比较高的层次上来阐述基于Ext JS3的应用怎么升级到Ext JS 4上面。在那么改动巨大的一个版本面前,我们没有办法,任何一本指南也没有办法把所有的升级的注意细节都全部提到。所以,我们额外的提供了chartingtreegrid 等组件的升级指南。更多的指南请参考start page

我们提供的兼容层主要采用重命名或者复写的方式来让Ext JS 3的应用基本能在Ext JS 4下面工作,但是在某些情况下,也不好使。所以,这个集成指南还列出了如果要使用兼容层来运行您的应用,您还需要注意和修改的地方。

Ext JS Migration Demo App

我们还提供了3组示例应用来演示怎么使用兼容层。示例应用展示了常用的组件,比如treetabpanelgridwindowformchartdata storesborder layout的升级方式。下载的包中包括:

· 使用Ext JS 3.3.1编写的一个标准应用

· 使用兼容层将该应用运行在Ext 4之下的应用示例。我们采用的都是小的修改代价,并且所有的注意事项我们都写在了注释当中。你可以在运行应用的时候注意查看在console中打印的一些警告信息。

· 完全升级到Ext JS 4的相同的应用,没有使用兼容层。

Ext JS Migration Screencasts

作为升级包的一部分,我们提供了一个2段的手把手教您升级到Ext JS 4的视频。第一个视频介绍了怎么使用兼容层来将您的应用运行在Ext JS 4之上。第二个视频重点介绍了怎么脱离兼容层将整个应用完整的迁移到Ext JS 4之上的过程,该视频还演示了怎么样将Ext JS 3中自定义的类迁移到Ext JS 4的类体系上,并使用4提供了自动类加载机制。

View the video tutorials: Ext JS 3 to 4 Migration Screencast Part 1 | Part 2

Continued Improvement

The compatibility layer and migration guide do not currently provide 100% of possible coverage of the API changes in Ext JS 4. Due to the sheer amount of effort and complexity involved in mapping all of the API's that changed across the entire framework, the compatibility layer has by necessity been trailing the changes to the framework itself. However, because many people are ready to dive into Ext JS 4 today, we wanted to make these resources available as soon as possible.

Development on the Migration Pack will continue for now, with additional update releases, until it reaches the point where most of the API that can be mapped is mapped. We'll never get to 100%, but we can get pretty close. There are bound to be questions and issues that arise once people start testing this out. Please use the Ext JS 3 to 4 Migration thread on the Sencha Forum as your primary source for discussing migration issues, rather than posting questions here in the blog comments.

As always we welcome your feedback, and we hope that these resources will help everyone to quickly upgrade to the latest and greatest framework that Sencha has to offer!

 

原文地址:http://www.sencha.com/blog/ext-js-3-to-4-migration/



3.62K